Установка cmake 2.8.8+ на Ubuntu 12.10

При установке OpenCV 3.1.0 на Ubuntu 12.10 возникла проблема с утилитой cmake, которая устойчиво выдавала ошибку find_package called with invalid argument «CONFIG». Подозрение пало на утилиту cmake, которая имела версию 2.8.7, а аргумент CONFIG поддерживается с версии 2.8ю8. Обновить через apt-get не получилось.

Поэтому пришлось делать всё в ручном режиме

1. Скачать исходники cmake с официального сайта

2. Распаковать их ($ tar -zxvf cmake-<version>.tar.gz)

3. Создать директорию _build (mkdir _build) и перейти в неё (cd _build)

4. Запустить следующие команды

cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
make
sudo make install
sudo ldconfig
  1. Пока что нет комментариев.
  1. Пока что нет уведомлений.